Author Topic: Glowing Red Turbine Housing  (Read 3029 times)

0 Members and 1 Guest are viewing this topic.

notstock88

  • Sr. Member
  • *****
  • Posts: 171
Glowing Red Turbine Housing
« on: August 13, 2014, 04:06:24 PM »
I run a T4 header and my turbo is a 6062. The turbine housing is a full T4 with a .68a/r and has a 3" v-band outlet. My exhaust is a mandrel bent 3" catless with a muffler.

My "issue" is that even if i am driving off boost, just tooling around town, when i get home i pop the hood  my turbine housing is glowing red around the 3" outlet, where the exhaust pipe connects. Why would this get this hot when i am not even pushing the car hard?

FunkyPhil

  • Administrator
  • Hero Member
  • *****
  • Posts: 1299
Re: Glowing Red Turbine Housing
« Reply #1 on: August 14, 2014, 09:55:25 PM »
valve timing and/or ignition timing
87 Conquest Tsi: 519whp 519wtq 7.09@102--10.95@122
CLICK TO SEE BUILD

Sqr

  • TBI Guy
  • TBi WHP KING
  • Sr. Member
  • *
  • Posts: 347
Re: Glowing Red Turbine Housing
« Reply #2 on: August 15, 2014, 08:47:19 AM »
valve timing and/or ignition timing
And as such the cam choice it's self is suspect. Ignition timing and timing pickups and cam timing (assuming) an adjustable cam gear, would be the first place to check to see if anything moved from where it was set.

FunkyPhil

  • Administrator
  • Hero Member
  • *****
  • Posts: 1299
Re: Glowing Red Turbine Housing
« Reply #3 on: August 15, 2014, 09:58:58 AM »
Yeah, considering his powercurve and low power numbers, Im going with over advanced cam.
87 Conquest Tsi: 519whp 519wtq 7.09@102--10.95@122
CLICK TO SEE BUILD

Sqr

  • TBI Guy
  • TBi WHP KING
  • Sr. Member
  • *
  • Posts: 347
Re: Glowing Red Turbine Housing
« Reply #4 on: August 15, 2014, 10:44:30 AM »
http://www.sqperformance.com/forum/index.php?topic=82.0

To me it does not look that bad, but the hp to tq ratio and curves are more typical of a smaller turbo and or tbi car.

Phil are you saying a 60 / 62 should have put up more hp and less tq?

FunkyPhil

  • Administrator
  • Hero Member
  • *****
  • Posts: 1299
Re: Glowing Red Turbine Housing
« Reply #5 on: August 15, 2014, 10:04:46 PM »
Well, Its got a tubular manifold, 6062 in a T4 housing, and a screamin banshee. Theres no good reason for tq to fall off like it is other than incorrect valve events. Hp is peaking at 53-5400rpm and then its done playing.

Hey Eric, bring an adjustable cam gear to TX with you.
87 Conquest Tsi: 519whp 519wtq 7.09@102--10.95@122
CLICK TO SEE BUILD

Sqr

  • TBI Guy
  • TBi WHP KING
  • Sr. Member
  • *
  • Posts: 347
Re: Glowing Red Turbine Housing
« Reply #6 on: August 15, 2014, 10:57:47 PM »
If he does not have a adjustable gear then the cam timing would be retarded? Unless he advanced it one tooth? Which probably would have been to much.

FunkyPhil

  • Administrator
  • Hero Member
  • *****
  • Posts: 1299
Re: Glowing Red Turbine Housing
« Reply #7 on: August 15, 2014, 11:01:40 PM »
retarded would explain the glow.

On this last build, i had the
block skimmed .010 and when i put everything together with the sproket in the position, It was 12deg advanced from the previous engine.......?

Thats whatade me think advanced. It didnt mph and power died early.
87 Conquest Tsi: 519whp 519wtq 7.09@102--10.95@122
CLICK TO SEE BUILD